Microsoft Excel Avanzado 2010

Funciones estadísticas

 

 

 

 

Función CONTAR

 

Descripción

La función CONTAR cuenta la cantidad de celdas que contienen números y cuenta los números dentro de la lista de argumentos. Use la función CONTAR para obtener la cantidad de entradas en un campo de número de un rango o matriz de números. Por ejemplo, puede escribir la siguiente fórmula para contar los números en el rango A1:A20:

=CONTAR(A1:A20)

En este ejemplo, si cinco de las celdas del rango contienen números, el resultado es 5.

Sintaxis

CONTAR(valor1; [valor2]; ...)

La sintaxis de la función CONTAR tiene los siguientes argumentos (argumento: valor que proporciona información a una acción, un evento, un método, una propiedad, una función o un procedimiento.):

*     valor1  Obligatorio. Primer elemento, referencia de celda o rango en el que desea contar números.

*     valor2; ...  Opcional. Hasta 255 elementos, celdas de referencia o rangos adicionales en los que desea contar números.

 Nota    Los argumentos pueden contener o hacer referencia a una variedad de diferentes tipos de datos, pero sólo se cuentan los números.

Observaciones

*     Se cuentan argumentos que son números, fechas o una representación de texto de los números (por ejemplo, un número entre comillas, como "1").

*     Se tienen en cuenta los valores lógicos y las representaciones textuales de números escritos directamente en la lista de argumentos.

*     No se cuentan los argumentos que sean valores de error o texto que no se puedan traducir a números.

*     Si un argumento es una matriz o una referencia, sólo se considerarán los números de esa matriz o referencia. No se cuentan celdas vacías, valores lógicos, texto o valores de error de la matriz o de la referencia.

*     Si desea contar valores lógicos, texto o valores de error, use la funciónCONTARA.

*     Si desea contar sólo números que cumplan con determinados criterios, use la función CONTAR.SI o la función CONTAR.SI.CONJUNTO.

Ejemplo

El ejemplo será más fácil de entender si lo copia en una hoja de cálculo en blanco.

1.            Seleccione el ejemplo de este artículo.

Importante  No seleccione los encabezados de columna o de fila.

Seleccionar un ejemplo de la Ayuda

Seleccionar un ejemplo de la Ayuda

2.            Presione CTRL+C.

3.            En Excel, cree una hoja de cálculo o un libro en blanco.

4.            En la hoja de cálculo, seleccione la celda A1 y presione CTRL+V.

Importante  Para que el ejemplo funcione correctamente, debe pegarlo en la celda A1 de la hoja de cálculo.

5.            Para cambiar entre ver los resultados y ver las fórmulas que devuelven los resultados, presione Alt+º, o en la ficha Fórmulas, en el grupo Auditoría de fórmulas, haga clic en el botón Mostrar fórmulas.

Después de copiar el ejemplo en una hoja de cálculo en blanco, puede adaptarlo a sus necesidades.

 

1

2

3

4

5

6

7

8

9


10


11


12

A

B

C

Datos

Ventas

8/12/2008

 

19

22,24

VERDADERO

DIV/0!

Fórmula

Descripción

Resultado

=CONTAR(A2:A8)

Cuenta la cantidad de celdas que contienen números en las celdas de A2 a A8.

3

=CONTAR(A5:A8)

Cuenta la cantidad de celdas que contienen números en las celdas de A5 a A8.

2

=CONTAR(A2:A8;2)

Cuenta la cantidad de celdas que contienen números en las celdas de A2 a A8 y el valor 2

4

 

 

Función CONTAR.SI

 

Descripción

La función CONTAR.SI cuenta el número de celdas dentro de un rango que cumplen un solo criterio especificado por el usuario. Por ejemplo, puede contar todas las celdas que comienzan con cierta letra, o bien todas las celdas que contienen un número mayor o menor que un número especificado por el usuario. Por ejemplo, suponga que tiene una hoja de cálculo que contiene una lista de tareas en la columna A y el primer nombre de la persona asignada a cada tarea en la columna B. Puede usar la función CONTAR.SI para contar cuántas veces aparece el nombre de una persona en la columna B y, de esa forma, determinar cuántas tareas tiene asignadas. Por ejemplo:

=CONTAR.SI(B2:B25,"Nancy")

 Nota    Para contar celdas basándose en varios criterios, vea la función CONTAR.SI.CONJUNTO.

Sintaxis

CONTAR.SI(rango;criterios)

La sintaxis de la función CONTAR.SI tiene los siguientes argumentos (argumento: valor que proporciona información a una acción, un evento, un método, una propiedad, una función o un procedimiento.):

*     rango  Obligatorio. Una o más celdas que se van a contar, incluidos números o nombres, matrices o referencias que contengan números. Los valores en blanco y los de texto no se tienen en cuenta.

*     criterios  Obligatorio. Número, expresión, referencia de celda o cadena de texto que determina las celdas que se van a contar. Por ejemplo, los criterios pueden expresarse como 32, ">32", B4, "manzanas" o "32".

 Notas 

*         En los criterios se puede utilizar los caracteres comodín  — signo de interrogación (?) y asterisco (*) —. El signo de interrogación corresponde a un solo carácter cualquiera y el asterisco equivale a cualquier secuencia de caracteres. Si desea buscar un signo de interrogación o un asterisco reales, escriba una tilde (~) delante del carácter que desea buscar.

*         Los criterios no distinguen entre mayúsculas y minúsculas; por ejemplo, la cadena "manzanas" y la cadena "MANZANAS" corresponden a las mismas celdas.

Ejemplo

Ejemplo 1: fórmulas CONTAR.SI comunes

El ejemplo será más fácil de entender si lo copia en una hoja de cálculo en blanco.

Mostrar¿Cómo copio un ejemplo?

1.            Seleccione el ejemplo de este artículo.

Importante  No seleccione los encabezados de columna o de fila.

Seleccionar un ejemplo de la Ayuda

Seleccionar un ejemplo de la Ayuda

2.            Presione CTRL+C.

3.            En Excel, cree una hoja de cálculo o un libro en blanco.

4.            En la hoja de cálculo, seleccione la celda A1 y presione CTRL+V.

Importante  Para que el ejemplo funcione correctamente, debe pegarlo en la celda A1 de la hoja de cálculo.

5.            Para cambiar entre ver los resultados y ver las fórmulas que devuelven los resultados, presione Alt+º, o en la ficha Fórmulas, en el grupo Auditoría de fórmulas, haga clic en el botón Mostrar fórmulas.

Después de copiar el ejemplo en una hoja de cálculo en blanco, puede adaptarlo a sus necesidades.

 

1

2

3

4

5

6


7


8


9


10


11



12

A

B

C

Datos

Datos

manzanas

32

naranjas

54

melocotones

75

manzanas

86

Fórmula

Descripción

Resultado

=CONTAR.SI(A2:A5;"manzanas")

Número de celdas con manzanas en las celdas A2 a A5.

2

=CONTAR.SI(A2:A5;A4)

Número de celdas con melocotones en las celdas A2 a A5.

1

=CONTAR.SI(A2:A5;A3)+CONTAR.SI(A2:A5;A2)

Número de celdas con naranjas y manzanas en las celdas A2 a A5.

3

=CONTAR.SI(B2:B5;">55")

Número de celdas con un valor superior a 55 en las celdas B2 a B5.

2

=CONTAR.SI(B2:B5;"<>"&B4)

Número de celdas con un valor no igual a 75 en las celdas B2 a B5.

3

=CONTAR.SI(B2:B5;">=32")-CONTAR.SI(B2:B5;">85")

Número de celdas con un valor superior o igual a 32 e inferior o igual a 85 en las celdas B2 a A5.

3

Ejemplo 2: fórmulas CONTAR.SI que usan caracteres comodín y tratan con valores vacíos

El ejemplo será más fácil de entender si lo copia en una hoja de cálculo en blanco.

1.            Seleccione el ejemplo de este artículo.

Importante  No seleccione los encabezados de columna o de fila.

Seleccionar un ejemplo de la Ayuda

Seleccionar un ejemplo de la Ayuda

2.            Presione CTRL+C.

3.            En Excel, cree una hoja de cálculo o un libro en blanco.

4.            En la hoja de cálculo, seleccione la celda A1 y presione CTRL+V.

Importante  Para que el ejemplo funcione correctamente, debe pegarlo en la celda A1 de la hoja de cálculo.

5.            Para cambiar entre ver los resultados y ver las fórmulas que devuelven los resultados, presione Alt+º, o en la ficha Fórmulas, en el grupo Auditoría de fórmulas, haga clic en el botón Mostrar fórmulas.

Después de copiar el ejemplo en una hoja de cálculo en blanco, puede adaptarlo a sus necesidades.

 

1

2

3

4

5

6

7

8




9





10



11



12




13




14

A

B

C

Datos

Datos

manzanas

 

 

naranjas

No

melocotones

No

 

 

manzanas

Fórmula

Descripción

Resultado

=CONTAR.SI(A2:A7;"*es")

Número de celdas que acaban con las letras "es" en las celdas A2 a A7.

4

=CONTAR.SI(A2:A7;"?????es")

Número de celdas que acaban con las letras "es" y tienen exactamente 7 letras en las celdas A2 a A7.

2

=CONTAR.SI(A2:A7;"*")

Número de celdas que contienen cualquier texto en las celdas A2 a A7.

4

=CONTAR.SI(A2:A7;"<>"&"*")

Número de celdas que no contienen texto en las celdas A2 a A7.

2

=CONTAR.SI(B2:B7;"No") / FILAS(B2:B7)

Número promedio de votos negativos (incluidas las celdas vacías) de las celdas B2 a B7.

0,333333333

=CONTAR.SI(B2:B7;"Sí") / (FILAS(B2:B7) -CONTAR.SI(B2:B7; "<>"&"*"))

El número medio de votos afirmativos (excluidas las celdas vacías) de las celdas B2 a B7.

0,5

 

Función CONTAR.BLANCO

 

Descripción

Cuenta el número de celdas en blanco dentro de un rango.

Sintaxis

CONTAR.BLANCO(rango)

La sintaxis de la función CONTAR.BLANCO tiene los siguientes argumentos (argumento: valor que proporciona información a una acción, un evento, un método, una propiedad, una función o un procedimiento.):

*     Rango  Obligatorio. El rango dentro del cual desea contar el número de celdas en blanco.

Observación

También se cuentan las celdas que incluyen fórmulas que devuelven "" (texto vacío). Las celdas que contienen valores cero no se cuentan.

Ejemplo

El ejemplo será más fácil de entender si lo copia en una hoja de cálculo en blanco.

Mostrar¿Cómo copio un ejemplo?

1.            Seleccione el ejemplo de este artículo.

Importante  No seleccione los encabezados de columna o de fila.

Seleccionar un ejemplo de la Ayuda

Seleccionar un ejemplo de la Ayuda

2.            Presione CTRL+C.

3.            En Excel, cree una hoja de cálculo o un libro en blanco.

4.            En la hoja de cálculo, seleccione la celda A1 y presione CTRL+V.

Importante  Para que el ejemplo funcione correctamente, debe pegarlo en la celda A1 de la hoja de cálculo.

5.            Para cambiar entre ver los resultados y ver las fórmulas que devuelven los resultados, presione Alt+º, o en la ficha Fórmulas, en el grupo Auditoría de fórmulas, haga clic en el botón Mostrar fórmulas.

Después de copiar el ejemplo en una hoja de cálculo en blanco, puede adaptarlo a sus necesidades.

 

1

2

3

4

5

6


7

A

B

Datos

Datos

 

 

6

=SI(B4<30;"";B4)

 

27

4

34

Fórmula

Descripción (resultado)

=CONTAR.BLANCO(A2:B5)

Cuenta las celdas vacías existentes en el rango anterior. La fórmula devuelve texto vacío. (4)

 

 

 

 

Página Web creada con fines académicos sin ánimo de lucro.

TP en Sistemas e Informática – Primer Semestre - Nocturno